Workflow Steps for Jira - Request Verification Failing
Incident Report for Adaptavist Cloud Apps
Resolved
We have been monitoring the situation and can confirm that as of the last update the situation has been fully resolved. At roughly 1:30pm EST Slack inadvertently changed the format of a few core headers which caused request validations to fail on our end. We acted to adjust our logic in order to handle this unexpected change in the short term, which seems to have ultimately been rolled back on their end. All requests are now being correctly validated and app functionality is fully restored. We are sorry for any inconvenience this may have caused.
Posted Dec 20, 2023 - 02:32 UTC
Monitoring
A fix has been deployed and we will continue to monitor the situation to ensure it is fully resolved. We are sorry for any inconvenience this has caused.
Posted Dec 19, 2023 - 22:05 UTC
Identified
We are aware of an issue where requests to Workflow Steps for Jira are failing. Slack has changed the format of a key security header which is causing request validations on incoming app requests to fail. We are in the process of implementing a fix and will update when we have more information.
Posted Dec 19, 2023 - 20:37 UTC
This incident affected: Upscale (Workflow Steps for Jira).