Some customer scripts failed to execute in US region

Incident Report for Adaptavist Cloud Apps

Resolved

We’re confident the ScriptRunner Cloud issues are now resolved, so we’re closing this incident. If you experience any further issues, please contact our team. Apologies for the inconvenience
Posted Dec 31, 2025 - 15:10 UTC

Monitoring

All scripts are now running as normal.
We've implemented a fix that improves our fallback behaviour in the distributed cache system.
Posted Dec 30, 2025 - 12:33 UTC

Identified

We have identified the issue and we are deploying a patch
Posted Dec 30, 2025 - 09:58 UTC

Investigating

A minority of customer scripts didn't run in the US region.
This occurred between 12:30 and 16:30 on 29th December.
Posted Dec 29, 2025 - 12:30 UTC
This incident affected: ScriptRunner (ScriptRunner for Jira Cloud, ScriptRunner for Confluence Cloud).