Unable to edit Post-Functions that use non-English letters
Incident Report for Adaptavist Cloud Apps
Resolved
We have seen no further issues since deploying the fix for this earlier on today so are now marking this issue as resolved.
Posted 7 months ago. Nov 01, 2018 - 15:38 UTC
Monitoring
We believe our latest changes have finally resolved this problem. We will continue to monitor the situation and please get in touch directly on our support channels (https://productsupport.adaptavist.com/servicedesk/customer/portal/23/create/112) if your post-functions are not displaying correctly.
Posted 7 months ago. Nov 01, 2018 - 10:57 UTC
Update
We are rolling out another change that we are confident will resolve this problem.
Posted 7 months ago. Nov 01, 2018 - 10:21 UTC
Identified
We think we have identified the cause of the problems and are working on testing a fix.
Posted 7 months ago. Oct 31, 2018 - 13:59 UTC
Update
We are still working to identify the cause of this issue and will post a further update once the cause of this issue has been diagnosed.
Posted 7 months ago. Oct 30, 2018 - 15:59 UTC
Update
We're rolling out additional logging to help diagnose the problem. We'll post back here with an update as our investigation continues.
Posted 7 months ago. Oct 26, 2018 - 09:56 UTC
Investigating
We are currently aware of problem editting post-functions that have been previously saved with non-English letters including, but not limited to European languages (é, ç, ü, ß, ¿, ¡ etc), Cyrillic, Chinese, Japanese, Korean and others. Workflow Post-functions are still being run, it is just not possible to edit them at this time.
Posted 7 months ago. Oct 26, 2018 - 08:10 UTC
This incident affected: ScriptRunner for Jira Cloud (ScriptRunner Service).