Filter syncing maybe delayed for ScriptRunner customers

Incident Report for Adaptavist Cloud Apps

Resolved

All issues with filter syncing have now been resolved. Thank you for your patience.
Posted Jul 18, 2025 - 08:17 UTC

Update

We are waiting for a fix to reach production and continue to monitor the situation.
Posted Jul 17, 2025 - 08:04 UTC

Update

We are no longer seeing any issues in ScriptRunner ES for the EU region. There are very few issues in US region and only in relation to users with filters related to issueFieldMatch.
Posted Jul 15, 2025 - 15:33 UTC

Monitoring

We are currently monitoring the response to the changes.
Posted Jul 14, 2025 - 08:59 UTC

Identified

An issue has been identified and fix deployed.
Posted Jul 14, 2025 - 08:59 UTC

Update

We are going to continue investigating this issue on Monday. We are confident that the impact is currently low, and that only in a small minority of cases will filters take slightly longer to sync than usual. We will continue to update this incident when we have more information.
Posted Jul 11, 2025 - 16:52 UTC

Update

We are still investigating this issue and will provide further updates as those become available
Posted Jul 11, 2025 - 15:55 UTC

Update

We are still investigating the root cause, the fix which has been deployed so far has not mitigated the issue.
Posted Jul 11, 2025 - 11:26 UTC

Update

We are continuing to investigate the remaining errors affecting a small subset of customers. Further updates will be provided as new information becomes available.
Posted Jul 10, 2025 - 21:02 UTC

Update

The most recent fix did not stop all errors. However, only a very small percentage of filters and customers are affected. A team will continue to monitor and investigate the situation.
Posted Jul 10, 2025 - 16:54 UTC

Update

We have now identified an issue and are deploying a fix.
Posted Jul 10, 2025 - 16:05 UTC

Update

We have made some changes in configuration and are monitoring the situation.
Posted Jul 10, 2025 - 15:27 UTC

Investigating

We've noticed some errors in the service responsible for filter syncing. This means that some filters might not be syncing and require manual sync. We are currently investigating this issue and will provide an update when we've found the root of the problem.
Posted Jul 10, 2025 - 14:33 UTC
This incident affected: ScriptRunner (ScriptRunner for Jira Cloud).