Workflow Steps for Jira: Degraded performance
Incident Report for Adaptavist Cloud Apps
Resolved
We have been actively monitoring the situation and can confirm that the incident has been resolved.

At 9:30am EST an issue with a downstream service caused some unexpected rate limiting which resulted in some workflow executions to hang or fail. This also may have affected the ability to edit workflows as well. The issue was resolved and as of 10:23am EST functionality was properly restored. We apologize for any inconvenience.
Posted May 22, 2023 - 19:23 UTC
Monitoring
We identified a recent change that could result in errors running or editing workflows. The change has been reverted and we are currently monitoring the situation. We apologize for any inconvenience.
Posted May 22, 2023 - 14:47 UTC
Investigating
We're aware of an issue that might be causing degraded performance running and editing workflows. We are looking into it and will let you know when we have more info.
Posted May 22, 2023 - 14:22 UTC
This incident affected: Upscale (Workflow Steps for Jira).