Error obtaining authentication tokens from Atlassian due to recent outages
Incident Report for Adaptavist Cloud Apps
Resolved
After consulting with Atlassian we have determined that in order to permanently resolve the issues caused by Atlassian, users will have to re-authenticate with their Jira cloud instance to restore their workflow functionality. We have sent an in app message to all users with more detailed information on this. We thank you for all your patience throughout this whole ordeal and apologize for the inconvenience having to re-authenticate causes.

We are considering this issue resolved as it has a confirmed permanent solution, please don't hesitate to reach out on our support portal if you have any further questions or concerns.
Posted Apr 14, 2022 - 21:13 UTC
Update
We continue to monitor the situation affecting some of our Jira Cloud users. The app requires a regularly rotated authentication token from Atlassian to interact with your Jira instance. Recent Atlassian outages (https://status.atlassian.com) have interfered with this process and are the source of these errors.
Here's a workaround that resolves the issue in most cases: Re-authenticate with the Jira connection. If your Jira Cloud instance is online, this restores the affected workflows and allows the app to continue to perform as expected. There's no harm in re-authenticating with Jira to ensure your workflows are executing properly. Atlassian has already restored connectivity for some affected users, though it could be days until the restorations are complete. We will continue to monitor Atlassian's progress and make updates to this status space as they are available. Thank you for your patience.
Posted Apr 13, 2022 - 17:50 UTC
Identified
We have continued to monitor the situation and have carried out a thorough investigation into the impact to our Jira Cloud users. Due to recent Atlassian outages (https://status.atlassian.com), errors that request authentication tokens from Atlassian are appearing in our app. Temporarily, re-authenticating with the connection is a workaround fix for the issue. We are constantly monitoring and researching this issue with Atlassian, and we hope to have a permanent solution ASAP. Thank you for your patience
Posted Apr 11, 2022 - 17:00 UTC
Investigating
WORKFLOW STEPS FOR JIRA USERS: We have become aware of an issue that is affecting some of our Jira Cloud users. Errors related to obtaining authentication tokens from Atlassian are appearing, which may or may not be related to recent Atlassian outages. Currently, re-authenticating with the connection seems to address the issue. We are investigating and hope to have more info soon. Updates will be posted here on Statuspage as they are available. Thank you for your patience!
Posted Apr 07, 2022 - 13:00 UTC
This incident affected: Workflow Steps for Jira (Workflow Steps for Jira).