Save Permissions not showing or saving correctly for Enhanced Search filters
Incident Report for Adaptavist Cloud Apps
Resolved
The incident has been resolved.

Any customers who attempted to view, edit or create an enhanced search filter in either Enhanced Search standalone or ScriptRunner Enhanced Search between August 23rd 2022, 5:01:45 pm UTC and August 24th 2022, 12:31:00 pm UTC may have experienced issues. Please check your filter permissions are as expected if you edited or created any filters during this period as some permissions could be missing.
Posted Aug 24, 2022 - 14:07 UTC
Monitoring
We have deployed the fix for Enhanced Search standalone and permissions should be showing again now appropriately. We will continue to monitor the situation and gather information on what impact this has had on customers.
Posted Aug 24, 2022 - 12:31 UTC
Update
The permissions for Enhanced Search standalone are still not appearing as expected. We are continuing to investigate this.
Posted Aug 24, 2022 - 12:30 UTC
Update
We have deployed a fix for Scriptrunner Enhanced Search and will monitor the situation. The fix for Enhanced Search standalone is still deploying
Posted Aug 24, 2022 - 12:24 UTC
Update
We believe the issue is actually not adding permission changes, other than group permission changes. The fix that is currently deploying should fix this issue.
Posted Aug 24, 2022 - 11:54 UTC
Identified
We believe that some permissions will not be showing accurately for Enhanced Search filters on the Enhanced Search filter screen. We believe that any edits to permissions will have been saved, but they won't necessarily be displaying correctly on the UI. We have created a fix and are in the process of deploying this.
Posted Aug 24, 2022 - 11:50 UTC
Investigating
We are aware of a potential issue where Enhanced Search filter permissions are not saving. We are looking into the issue and will release a fix as soon as possible. Sorry for the inconvenience caused. This is only effecting Enhanced Search standalone and the Enhanced Search feature of ScriptRunner.
Posted Aug 24, 2022 - 11:36 UTC
This incident affected: ScriptRunner for Jira Cloud (ScriptRunner Service) and Enhanced Search for Jira Cloud (Enhanced Search Services).