ScriptRunner for Jira Cloud Scripts not running and 401 Unauthorized errors
Incident Report for Adaptavist Cloud Apps
Resolved
Everything looks normal according to our logs and metrics, therefore we are considering this incident over.

Apologies for any inconvenience.
Posted May 07, 2021 - 16:26 UTC
Monitoring
We have restarted our services and believe that as of 15:42 UTC scripts are now executing as expected again.

Unfortunately, any Script Listener or Post-Function scripts executed between 13:00 UTC and 15:42 UTC will not have been run and will not be retried. Please re-run these scripts again.

We will continue to monitor this incident.
Posted May 07, 2021 - 15:55 UTC
Investigating
We are now experiencing a new issue following the earlier incident. One symptom of the new issue is that not all user scripts are running.

We are currently investigating the cause of this issue.
Posted May 07, 2021 - 15:20 UTC
Monitoring
We have identified the cause and resolved this issue.

However, there may be a delay in executing scripts until all queued scripts have been processed. We apologise for this delay.

We will continue to monitor the situation.
Posted May 07, 2021 - 14:45 UTC
Investigating
We are aware of an issue that is causing ScriptRunner for Jira Cloud to return a 401 Unauthorized or "Unknown Error" for certain pages.

We are currently investigating this issue and we will post any updates as we get them here.
Posted May 07, 2021 - 14:12 UTC
This incident affected: ScriptRunner for Jira Cloud (ScriptRunner Service).