Slow responses from REST API requests
Incident Report for Adaptavist Cloud Apps
Resolved
We have released fix and now all is working as expected.
Posted about 2 months ago. Aug 21, 2018 - 15:17 UTC
Update
Today we are releasing changes to some customers to alleviate the problem.
Posted about 2 months ago. Aug 21, 2018 - 08:25 UTC
Update
We are in the process of re-implementing the affected part of our system to work around the problem.
Posted 2 months ago. Aug 17, 2018 - 13:22 UTC
Update
Morning - we are now continuing our investigation into the long REST API request times.
Posted 2 months ago. Aug 16, 2018 - 07:33 UTC
Update
Unfortunately our changes have not made the improvements we desired. We'll continue investigating this problem tomorrow.
Posted 2 months ago. Aug 15, 2018 - 21:43 UTC
Update
We have successfully deployed one set of changes to remove the delay in processing REST API calls from customer scripts and are deploying another change to remove the delay when our services make requests to Jira Cloud.
Posted 2 months ago. Aug 15, 2018 - 21:07 UTC
Update
We are releasing a new set of changes that should mitigate the problem of REST API calls taking a long time. We'll post back here when that change has been released.
Posted 2 months ago. Aug 15, 2018 - 20:09 UTC
Update
We are still seeing the same long request time problems in our latest release. We'll continue to investigate and release any new fixes that we uncover as the day continues.
Posted 2 months ago. Aug 15, 2018 - 16:25 UTC
Update
The temporary workaround has not yet been released because of automated test failures. We are working to fix the relevant tests in order to release the change as soon as possible.
Posted 2 months ago. Aug 15, 2018 - 14:02 UTC
Identified
We have found the root cause of the problem and a temporary workaround which we will release shortly which we investigate a long-term fix.
Posted 2 months ago. Aug 15, 2018 - 10:24 UTC
Investigating
We are aware of a problem where some REST API calls are returning very slowly - taking roughly 15 seconds. We are investigating the cause of this problem and are working to find a fix. If you need an immediate work-around, try using the built-in Java HTTP client instead of the Unirest client that we bundle into all scripts.
Posted 2 months ago. Aug 15, 2018 - 08:42 UTC
This incident affected: ScriptRunner for Jira Cloud (ScriptRunner Service).